Starkle Dream Up. Stephens College
« Back to Sc-Scene Archive

Stephens alumna Amy Bond ’92 to compete on Lifetime’s ‘Project Runway’

August 14, 2017

 

Amy Bond ’92 is one of 16 fashion designers who will compete on the 16th season of “Project Runway,” the popular, Emmy-Award winning reality television contest.

The season premieres at 7 p.m. CST, on Aug. 17, 2017, on Lifetime.

Bond, 46, isn’t the first Stephens alumna to appear on the show. Qristyl Frazier ’91 competed in season six in 2009 and made it through episode four of the competition. 

In an interview posted on the “Project Runway” website, Bond, who lives in Los Angeles, said she received an email inviting her to audition for the show. Although she has many years of experience, Bond said winning the competition requires more than sheer talent.

“We all have talent,” she said. “We wouldn’t have made it to the cast if we didn’t. Therefore, I don’t think it is a matter of discovering who “has it” and who doesn’t, but rather who can keep on task and on point. As an educator and seasoned professional, I have a thorough set of relevant skills and experiences to draw from and the maturity to implement them.”

After graduating from Stephens with a B.F.A. in Fashion Design, Bond worked as an assistant designer at St. Pucchi in L.A., before starting her own contemporary women’s clothing line in 1999. Eventually, she completed her M.F.A. in Fashion Design through the Academy of Art University’s online fashion program.

Bond has been a featured designer at many shows around Los Angeles and her previous residence of Las Vegas. She also showed at the Mercedes-Benz Fashion Week in New York in 2012. She has taught for several schools, including The Art Institute of Las Vegas, Otis College of Art and Design in L.A. and Kadenze Inc., which brings together educators, artists and engineers from leading universities across the globe to provide online education in the fields of art and creative technology.

Most computers will open PDF documents automatically, but you may need to download Adobe Reader.